Wiki Link: [discussion:429]
Missing Product.xml file for 2007 Primary Interop Assemblies 

Jun 3 2008 at 7:37 PM
I'm trying to create a sample setup project as outlined in the whitepaper at http://msdn.microsoft.com/en-us/library/cc563937.aspx. I am not able to see the 2007 Office Primary Interop assemblies as a prerequisite in the prerequisites dialog box. I have the o2007pia.msi file installed in the Program Files\Microsoft SDKs\Windwos\v6.0a\Bootstrapper\Packages\Office2007PIA directory. However, there is no Product.xml file associated with it. Thus, the assemblies are not shown as a prerequisite in Visual Studio 2008. The whitepaper led me to believe that this file would be included in the download provided on this site. However, when I extract the archive and look in the packages directory, there is no Office2007PIA directory. Can anyone point me in the right direction as to where to find this file?

Jun 3 2008 at 10:10 PM
I have the same problem. I don't think the redistributable for the PIAs was intended to be used in this way. That would explain why the file is missing.

I don't know why Microsoft can't just automate all these steps in Visual Studio.

Jun 3 2008 at 10:30 PM
It seems as if there was a lack of communication between the whitepaper writers and the sample code providers. Is there any way anyone can give me a working product.xml file so that I can at least continue through the tutorial. This would be extremely helpful!

Jun 3 2008 at 11:19 PM
I asked about this problem on the Visual Tools For Office forum and they told me to install the download sample that is part of the article "Deploying Visual Studio 2005 Tools for Office Second Edition Solutions Using Windows Installer"

http://msdn.microsoft.com/en-us/library/bb332051.aspx

After installation you get the following: %Program files%\Microsoft Visual Studio 2005 Tools for Office SE Resources\....\packages\Office2007PIA

It does look like it has the right files, but I haven't tried it yet.

Coordinator
Jun 4 2008 at 7:22 PM
hi all,

i apologize for the delay. i've added the Office2007PIA and Office2003PIA directories to the package directory in the samples download. the file in the Download tab has the PIA directories. thanks for finding this and letting us know about the error!

the VSTO product team is aware of the PIA deployment issues, and they are working on some changes. this involves much collaboration between the VS and Office teams, so stay tuned for more details.

m.


Updating...
Page view tracker