Wiki Link: [discussion:1725]
Error 0x80040216 using Plugin registration tool v2.2/2.0. 

May 13 2009 at 7:58 PM
Error 0x80040216 using Plugin registration tool v2.2/2.0.



I get the following error when trying to register an assembly. I was able to use this tool successfully for the past 6 months, then I just started getting this error on anything I try to do with the tool, ie Register, Disable step, etc.


Please help.


Unhandled Exception: System.Web.Services.Protocols.SoapException: Server was unable to process request.

Detail: <detail><error>

<code>0x80040216</code>

<description>An unexpected error occurred.</description>

<type>Platform</type>

</error></detail>

at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)

at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

at PluginRegistrationTool.CrmSdk.CrmService.Update(BusinessEntity entity) in C:\Users\bfeller.VIRTUAL\Documents\Visual Studio 2008\Projects\CrmSdk\pluginregistrationtool\Web References\CrmSdk\Reference.cs:line 345

at PluginRegistrationTool.RegistrationHelper.UpdateAssembly(CrmOrganization org, String pathToAssembly, CrmPluginAssembly assembly) in C:\Users\bfeller.VIRTUAL\Documents\Visual Studio 2008\Projects\CrmSdk\pluginregistrationtool\RegistrationHelper.cs:line 297

at PluginRegistrationTool.PluginRegistrationForm.btnRegister_Click(Object sender, EventArgs e) in C:\Users\bfeller.VIRTUAL\Documents\Visual Studio 2008\Projects\CrmSdk\pluginregistrationtool\pluginregistrationform.cs:line 290

Coordinator
Jun 12 2009 at 6:18 PM
Do you have privileges? Can you check the server traces?

Coordinator
Mar 5 2010 at 8:57 PM
0x80040216 is a very generic error message. You need to look at the server traces to figure out the issue.

Mar 17 2010 at 3:54 PM
Hello, any one found, the solution, I'm facing exactly the same error with no trace at the server I can find no explanation since I deployed my plugins a 100 times before, the same one just upgrading their logic.

:(

Coordinator
Mar 17 2010 at 7:03 PM
Can you enable tracing on the server?

Coordinator
Mar 17 2010 at 7:07 PM
Following article explains about tracing in CRM
http://support.microsoft.com/kb/907490

Feb 13 2012 at 4:48 AM
I found this article while problem solving a custom dll that I designed for CRM 4.0 but was trying to use in CRM 2011. After upgrading to 2011, the dll continued to work but I stopped being able to use the pluginregistrationtool to send updates to the DLL to the server. I tried using the new 2011 tool and had similiar problems. A secondary symptom was that if I deactivated a work flow that happened to contain one of the DLL calls, I was not able to reactivate it

Based on the timing of this discussion, the problem originally described had nothing to do with CRM 2011. However, I wanted to make a note of what the fix was for me in case any other CRM 2011 people stumble upon this.

I found that the fix was very simple. CRM 2011 has a new microsoft.crm.sdk.dll in the server\bin\ folder located on the CRM 2011 server. I grabbed that file and moved it to the machine that has Visual Studio on it. I removed the reference to the old microsoft.crm.sdk.dll and added a reference to the new dll. I then recompiled. At this point, I am able to use the 4.0 or 2011 pluginregistrationtool.

As a side note, I happened to move from Visual Studio 2008 to Visual Studio 2010 too. I don't believe that made a difference. I am fairly certain that the new dll was the trick.


Updating...
Page view tracker